Slow Zip File Downloads / Missing Photos
Incident Report for HDPhotoHub
Resolved
This incident has been resolved.
Posted Apr 18, 2022 - 11:59 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2022 - 11:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2022 - 09:59 PDT
Investigating
We are currently investigating this issue.
Posted Apr 18, 2022 - 09:05 PDT
This incident affected: Bulk Media Downloads.