Degraded Print Quality Zip File Download Speed
Incident Report for HDPhotoHub
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 13:41 PDT
Investigating
We are currently investigating an issue that is causing some "Print Quality Zip" file downloads to be slower than normal.
Posted Jun 09, 2022 - 09:39 PDT
This incident affected: Bulk Media Downloads.